Issues with Display Currency Rates Impacting Invoices and Payouts

Incident Report for Txn Platform

Resolved

This incident has been resolved.
Posted Jan 17, 2026 - 13:20 UTC

Identified

We are experiencing issues with display rates (such as CNY, TRY, etc), which is causing an inability for clients to create invoices and process payouts in display currencies. Other currencies are fully operational. The issue is traced to the 3rd party provider who have been working to resolve it as soon as possible. We will keep you updated.
Posted Jan 17, 2026 - 07:19 UTC
This incident affected: Production (Merchant API).