Issues with Rates Impacting Exchanges, Invoices and Payouts

Incident Report for Txn Platform

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 07:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2025 - 06:46 UTC

Identified

We are experiencing issues with exchange rates, which is causing an inability for clients to create exchanges, invoices and process payouts.
Posted Jul 18, 2025 - 06:09 UTC
This incident affected: Production (Merchant API, Exchange).